What would cause the Von Duprin delay egress Chexit device not to provide delay egress?

For Motor driven Chexit devices shipped from the factory after 8-24-2015, the Chexit Secure Relay Contacts( white and violet wires) change state to signal the device is not secure. 

Check the following:

  1. CX Motor Cable is disconnected, broken, or defective.
  2. CX Motor Assembly is defective.
  3. On a rim or vertical rod device, the latch bolt can't extend.
  4. On any device, the push pad is held in.


For Solenoid driven Chexit devices shipped from the factory prior to 8-24-2015, the following could cause the device not to provide delay egress:

  1. Measure the voltage between green and orange wires on three wire connector on CX module, you should measure 23-24 VDC when device is in arm mode.
  2. If there is no voltage between green and orange wires replace the CX module.
  3. If there is voltage between green and orange wires on the module, check the solenoid coil resistance and make sure green and orange wires measure 110 - 140 ohms. If there is no reading, replace the solenoid.
  4. You may also have issue with mechanical adjustments such as vertical rods. If rods are out of adjustment it could cause the solenoid to pull and drop and not allow any delay.

DISCLAIMER:

INFORMATION PROVIDED THROUGH THIS SITE IS PROVIDED TO YOU AS IS WITHOUT ANY EXPRESS REPRESENTATIONS OR WARRANTIES OF ANY KIND, AND WE MAKE NO REPRESENTATION OR WARRANTY THAT THIS SITE(OR ANY INFORMATION PROVIDED IN RESPONSE TO YOUR INQUIRY), WILL BE ACCURATE, COMPLETE, OR ERROR-FREE.

YOU AGREE THAT YOU MUST EVALUATE ALL INFORMATION AND RESPONSES, AND THAT YOU BEAR ALL RISKS ASSOCIATED WITH, THE USE OF THIS SITE, INCLUDING ANY RELIANCE ON THE ACCURACY,COMPLETENESS, OR USEFULNESS OF ANY INFORMATION OR MATERIALS MADE AVAILABLE THROUGH THIS SITE.

Other users ask

Question